易语言实地培训长期招生 QQ1615457736

乐易论坛

 找回密码
 立即注册

微信登录

微信扫码,快速开始

QQ登录

用QQ账号登陆

导航
导航
培训
培训
产品
产品
易歪歪客服聊天助手——永久免费阿里云服务器最高¥1888云产品通用代金券我要租广告
易歪歪客服聊天助手——永久免费阿里云服务器低至10元/月我要租广告
易歪歪客服聊天助手——永久免费最高2000云产品通用代金券我要租广告
查看: 48151|回复: 104
收起左侧

7、易汇编__stdcall、__cdcel和__fastcall的区别

[复制链接]
  • TA的每日心情
    奋斗
    昨天 08:56
  • 签到天数: 724 天

    [LV.9]以坛为家II

    发表于 2016-1-9 03:57:13 | 显示全部楼层 |阅读模式

    乐易编程网免费注册!抓住机会哦!

    您需要 登录 才可以下载或查看,没有帐号?立即注册

    x



    链接:
    游客,如果您要查看本帖隐藏内容请回复
    密码: 6yyw
    [ecode=0].版本 2

    .子程序 naked_Int
    .参数 a, 整数型
    .局部变量 开始标志, 整数型
    .局部变量 code, 字节集
    .局部变量 WEIZHI1, 整数型
    .局部变量 code1, 字节集
    .局部变量 结束标志, 整数型
    .局部变量 WEIZHI2, 整数型

    开始标志 = 取子程序地址_ (&naked_Start)
    WEIZHI1 = 寻找字节集 (指针到字节集 (a, 100), { 232 }, )
    .计次循环首 (8, )
        code = code + { 144 }
    .计次循环尾 ()
    结束标志 = 取子程序地址_ (&naked_End)
    WEIZHI2 = 寻找字节集 (指针到字节集 (a, 100), { 139, 229, 93, 195 }, ) + a - 6
    .计次循环首 (8, )
        code1 = code1 + { 144 }
    .计次循环尾 ()
    内存_写字节集 (进程_取自进程ID2 (), a, code)
    内存_写字节集 (进程_取自进程ID2 (), WEIZHI2, code1)



    .子程序 naked_Start



    .子程序 naked_End



    .子程序 被处理的函数

    naked_Start ()

    naked_End ()
    [/ecode]

    免费评分

    参与人数 1易币 +5 金钱 +5 收起 理由
    上官轩明 + 5 + 5

    查看全部评分

    易语言实地培训,报名联系QQ 1615457736
    [超强]《易语言软件加密(防破解)技术特训》
    回复

    使用道具 举报

  • TA的每日心情

    2019-1-26 21:23
  • 签到天数: 13 天

    [LV.3]偶尔看看II

    发表于 2018-12-28 14:10:55 | 显示全部楼层
    下载学习易汇编__stdcall、__cdcel和__fastcall的区别
    易语言实地培训,报名联系QQ 1615457736
    [超强]《易语言软件加密(防破解)技术特训》
    回复 支持 反对

    使用道具 举报

  • TA的每日心情

    2017-9-21 15:54
  • 签到天数: 5 天

    [LV.2]偶尔看看I

    发表于 2017-7-30 11:18:48 | 显示全部楼层
    下载学习易汇编__stdcall、__cdcel和__fastcall的区别
    易语言实地培训,报名联系QQ 1615457736
    [超强]《易语言软件加密(防破解)技术特训》
    回复 支持 反对

    使用道具 举报

  • TA的每日心情
    奋斗
    2018-5-30 17:32
  • 签到天数: 1 天

    [LV.1]初来乍到

    发表于 2017-12-11 16:14:59 | 显示全部楼层
    易汇编__stdcall、__cdcel和__fastcall的区别
    易语言实地培训,报名联系QQ 1615457736
    [超强]《易语言软件加密(防破解)技术特训》
    回复 支持 反对

    使用道具 举报

    该用户从未签到

    发表于 2016-1-9 03:58:00 | 显示全部楼层
    加入乐易vip,联系QQ:1615457734
    易语言实地培训,报名联系QQ 1615457736
    [超强]《易语言软件加密(防破解)技术特训》
    回复 支持 反对

    使用道具 举报

    该用户从未签到

    发表于 2016-1-9 03:58:20 | 显示全部楼层
    正需要呢,非常感谢楼主分享
    易语言实地培训,报名联系QQ 1615457736
    [超强]《易语言软件加密(防破解)技术特训》
    回复 支持 反对

    使用道具 举报

    该用户从未签到

    发表于 2016-1-9 04:12:51 | 显示全部楼层
    支持楼主了!
    易语言实地培训,报名联系QQ 1615457736
    [超强]《易语言软件加密(防破解)技术特训》
    回复 支持 反对

    使用道具 举报

  • TA的每日心情

    2017-7-20 20:16
  • 签到天数: 1 天

    [LV.1]初来乍到

    发表于 2016-1-9 04:19:35 | 显示全部楼层
    加入乐易vip,联系QQ:1615457734
    易语言实地培训,报名联系QQ 1615457736
    [超强]《易语言软件加密(防破解)技术特训》
    回复 支持 反对

    使用道具 举报

    该用户从未签到

    发表于 2016-1-9 04:48:36 | 显示全部楼层
    关注公众微信号:leybc_2015获得更多咨询
    易语言实地培训,报名联系QQ 1615457736
    [超强]《易语言软件加密(防破解)技术特训》
    回复 支持 反对

    使用道具 举报

    该用户从未签到

    发表于 2016-1-9 04:52:45 | 显示全部楼层
    看一下~~
    易语言实地培训,报名联系QQ 1615457736
    [超强]《易语言软件加密(防破解)技术特训》
    回复 支持 反对

    使用道具 举报

    该用户从未签到

    发表于 2016-1-9 05:00:43 | 显示全部楼层
    关注公众微信号:leybc_2015获得更多咨询
    易语言实地培训,报名联系QQ 1615457736
    [超强]《易语言软件加密(防破解)技术特训》
    回复 支持 反对

    使用道具 举报

    该用户从未签到

    发表于 2016-1-9 05:29:46 | 显示全部楼层
    正需要呢,非常感谢楼主分享
    易语言实地培训,报名联系QQ 1615457736
    [超强]《易语言软件加密(防破解)技术特训》
    回复 支持 反对

    使用道具 举报

    该用户从未签到

    发表于 2016-1-9 05:36:05 | 显示全部楼层
    支持楼主了!
    易语言实地培训,报名联系QQ 1615457736
    [超强]《易语言软件加密(防破解)技术特训》
    回复 支持 反对

    使用道具 举报

    您需要登录后才可以回帖 登录 | 立即注册

    本版积分规则

    关闭

    乐易推荐上一条 /6 下一条

    QQ|网站地图|Archiver|手机版|小黑屋|乐易论坛 ( 湘ICP备19007035号-2 )

    GMT+8, 2019-10-20 19:51 , Processed in 0.125783 second(s), 96 queries .

    Powered by Discuz! X3.4 Licensed

    © 2001-2017 Comsenz Inc.

    快速回复 返回顶部 返回列表