易语言实地培训长期招生 QQ1615457736

乐易论坛

 找回密码
 立即注册

微信登录

微信扫码,快速开始

QQ登录

用QQ账号登陆

导航
导航
培训
培训
产品
产品
易语言第5期实地培训火热招生TQApiEc---专为PCQQ/TIM 开发的API接口模块,让你直接调用内部功能WxApiEc-专为PCWx开发的API接口模块,让你快速调用内部功能
易语言第5期实地培训火热招生TQApiEc---专为PCQQ/TIM 开发的API接口模块,让你直接调用内部功能WxApiEc-专为PCWx开发的API接口模块,让你快速调用内部功能
易语言第5期实地培训火热招生TQApiEc---专为PCQQ/TIM 开发的API接口模块,让你直接调用内部功能WxApiEc-专为PCWx开发的API接口模块,让你快速调用内部功能
易歪歪客服聊天助手——永久免费易歪歪客服聊天助手——永久免费易歪歪客服聊天助手——永久免费
广告位招租广告位招租广告位招租
云课堂动态
查看: 75506|回复: 266
收起左侧

3、易汇编寄存器高低位详细讲解

[复制链接]
  • TA的每日心情
    奋斗
    昨天 04:52
  • 签到天数: 920 天

    [LV.10]以坛为家III

    发表于 2016-1-4 10:18:07 | 显示全部楼层 |阅读模式



    链接:
    游客,如果您要查看本帖隐藏内容请回复
    游客,如果您要查看本帖隐藏内容请回复

    [ecode=0].版本 2
    .支持库 spec

    .子程序 取高位, 整数型
    .参数 数, 整数型
    .局部变量 二, 文本型
    .局部变量 Ax, 文本型
    .局部变量 ah, 文本型

    二 = 十到二 (数)
    置入代码 ({ 144, 144, 144, 144 })  ' nop/nop/nop/nop

    Ax = 取文本右边 (二, 16)
    ah = 取文本左边 (Ax, 8)
    置入代码 ({ 144, 144, 144, 144 })  ' nop/nop/nop/nop
    返回 (二到十 (ah))

    .子程序 取低位, 整数型
    .参数 数, 整数型
    .局部变量 二, 文本型
    .局部变量 Ax, 文本型
    .局部变量 al, 文本型

    二 = 十到二 (数)
    Ax = 取文本右边 (二, 16)
    al = 取文本右边 (Ax, 8)
    返回 (二到十 (al))

    .子程序 取Ax, 整数型
    .参数 数, 整数型
    .局部变量 二, 文本型
    .局部变量 Ax, 文本型

    二 = 十到二 (数)
    Ax = 取文本右边 (二, 16)
    返回 (二到十 (Ax))

    .子程序 取高位A, 字节型
    .参数 数, 整数型
    .局部变量 x, 整数型

    置入代码 ({ 144, 144, 144, 144 })  ' nop/nop/nop/nop
    置入代码 ({ 139, 69, 8, 136, 101, 252 })
    置入代码 ({ 144, 144, 144, 144 })  ' nop/nop/nop/nop
    ' mov eax,[arg.1]
    ' mov [local.1],ah
    返回 (x)


    .子程序 取高低位
    .参数 数, 整数型
    .局部变量 字节, 字节集
    .局部变量 AX, 整数型
    .局部变量 AH, 字节型
    .局部变量 AL, 字节型

    字节 = 到字节集 (数)
    AX = 取字节集数据 (到字节集 (字节 [1]) + 到字节集 (字节 [2]) + { 0, 0 }, 3, )
    AH = 取字节集数据 (到字节集 (字节 [2]) + { 0, 0, 0 }, 1, )
    AL = 取字节集数据 (到字节集 (字节 [1]) + { 0, 0, 0 }, 1, )

    调试输出 (AX, AH, AL)
    [/ecode]

    本帖子中包含更多资源

    您需要 登录 才可以下载或查看,没有帐号?立即注册

    x
    易语言实地培训,报名联系QQ 1615457736
    [超强]《易语言软件加密(防破解)技术特训》
    回复

    使用道具 举报

  • TA的每日心情
    郁闷
    2018-10-14 11:34
  • 签到天数: 46 天

    [LV.5]常住居民I

    发表于 2018-12-30 15:56:43 | 显示全部楼层
    来看看哈         
    易语言实地培训,报名联系QQ 1615457736
    [超强]《易语言软件加密(防破解)技术特训》
    回复 支持 反对

    使用道具 举报

    头像被屏蔽

    该用户从未签到

    发表于 2016-1-8 20:01:16 | 显示全部楼层
    上班时间和上课时间冲突,只能下载视频看了
    易语言实地培训,报名联系QQ 1615457736
    [超强]《易语言软件加密(防破解)技术特训》
    回复 支持 反对

    使用道具 举报

  • TA的每日心情
    慵懒
    2018-10-18 17:25
  • 签到天数: 14 天

    [LV.3]偶尔看看II

    发表于 2019-3-26 13:41:13 | 显示全部楼层
    哒哒哒哒哒哒多多多多多多多多多多
    易语言实地培训,报名联系QQ 1615457736
    [超强]《易语言软件加密(防破解)技术特训》
    回复 支持 反对

    使用道具 举报

  • TA的每日心情
    慵懒
    2020-5-19 10:11
  • 签到天数: 122 天

    [LV.7]常住居民III

    发表于 2016-1-4 14:29:37 | 显示全部楼层
    fadsafdsaf ds
    易语言实地培训,报名联系QQ 1615457736
    [超强]《易语言软件加密(防破解)技术特训》
    回复 支持 反对

    使用道具 举报

    该用户从未签到

    发表于 2016-1-4 21:14:23 | 显示全部楼层
    下载学习了.
    易语言实地培训,报名联系QQ 1615457736
    [超强]《易语言软件加密(防破解)技术特训》
    回复 支持 反对

    使用道具 举报

  • TA的每日心情
    郁闷
    昨天 10:16
  • 签到天数: 202 天

    [LV.7]常住居民III

    发表于 2016-1-5 21:31:58 | 显示全部楼层
    懵懵懂懂之间呀~~~
    易语言实地培训,报名联系QQ 1615457736
    [超强]《易语言软件加密(防破解)技术特训》
    回复 支持 反对

    使用道具 举报

  • TA的每日心情
    擦汗
    2018-11-3 19:55
  • 签到天数: 7 天

    [LV.3]偶尔看看II

    发表于 2016-1-5 22:30:54 | 显示全部楼层
    不错哦,学习一下下
    易语言实地培训,报名联系QQ 1615457736
    [超强]《易语言软件加密(防破解)技术特训》
    回复 支持 反对

    使用道具 举报

  • TA的每日心情
    奋斗
    2020-5-2 13:12
  • 签到天数: 25 天

    [LV.4]偶尔看看III

    发表于 2016-1-6 00:19:36 | 显示全部楼层
    谢谢分享视频
    易语言实地培训,报名联系QQ 1615457736
    [超强]《易语言软件加密(防破解)技术特训》
    回复 支持 反对

    使用道具 举报

  • TA的每日心情

    2018-10-23 16:31
  • 签到天数: 4 天

    [LV.2]偶尔看看I

    发表于 2016-1-6 15:53:02 | 显示全部楼层
    高低位详细讲解
    易语言实地培训,报名联系QQ 1615457736
    [超强]《易语言软件加密(防破解)技术特训》
    回复 支持 反对

    使用道具 举报

    该用户从未签到

    发表于 2016-1-6 18:42:31 | 显示全部楼层
    取经
    易语言实地培训,报名联系QQ 1615457736
    [超强]《易语言软件加密(防破解)技术特训》
    回复

    使用道具 举报

    该用户从未签到

    发表于 2016-1-7 10:14:27 | 显示全部楼层
    乐易编程网,从业余到大神的进步!www.leybc.com
    易语言实地培训,报名联系QQ 1615457736
    [超强]《易语言软件加密(防破解)技术特训》
    回复 支持 反对

    使用道具 举报

    该用户从未签到

    发表于 2016-1-7 10:14:39 | 显示全部楼层
    加入乐易vip,联系QQ:1615457734
    易语言实地培训,报名联系QQ 1615457736
    [超强]《易语言软件加密(防破解)技术特训》
    回复 支持 反对

    使用道具 举报

    您需要登录后才可以回帖 登录 | 立即注册

    本版积分规则

    关闭

    乐易推荐上一条 /6 下一条

    QQ|网站地图|Archiver|手机版|小黑屋|乐易论坛 ( 湘ICP备19007035号-2 )

    GMT+8, 2020-5-27 04:11 , Processed in 0.068302 second(s), 128 queries .

    Powered by Discuz! X3.4 Licensed

    © 2001-2017 Comsenz Inc.

    快速回复 返回顶部 返回列表