易语言实地培训长期招生 QQ1615457736

乐易论坛

 找回密码
 立即注册

微信登录

微信扫码,快速开始

QQ登录

用QQ账号登陆

导航
导航
培训
培训
产品
产品
易歪歪客服聊天助手——永久免费阿里云服务器最高¥1888云产品通用代金券我要租广告
易歪歪客服聊天助手——永久免费阿里云服务器低至10元/月我要租广告
易歪歪客服聊天助手——永久免费最高2000云产品通用代金券我要租广告
查看: 19259|回复: 38
收起左侧

2、易汇编常见寄存器介绍以及使用

[复制链接]
  • TA的每日心情
    奋斗
    5 小时前
  • 签到天数: 637 天

    [LV.9]以坛为家II

    发表于 2016-1-2 22:41:46 | 显示全部楼层 |阅读模式

    乐易编程网免费注册!抓住机会哦!

    您需要 登录 才可以下载或查看,没有帐号?立即注册

    x
    链接:
    游客,如果您要查看本帖隐藏内容请回复
    游客,如果您要查看本帖隐藏内容请回复


    [ecode=0].版本 2

    .程序集 窗口程序集_启动窗口

    .子程序 __启动窗口_创建完毕
    .局部变量 a, 整数型

    置入代码 ({ 144, 144, 144, 144 })  ' nop/nop/nop/nop
    a = 取EIP ()
    置入代码 ({ 144, 144, 144, 144 })  ' nop/nop/nop/nop
    信息框 (取十六进制文本 (a), 0, , )

    .子程序 交换数据
    .参数 a, 整数型, 参考, a=12 EBP+8=指针
    .参数 b, 整数型, 参考


    置入代码 ({ 139, 69, 8 })  ' mov eax,[ebp+08] 取a的指针
    置入代码 ({ 139, 8 })  ' mov ecx,[eax] 取A的值
    置入代码 ({ 139, 93, 12 })  ' mov ebx,[ebp+0CH] 取B的指针
    置入代码 ({ 139, 19 })  ' mov edx,[ebx] 取B的值
    置入代码 ({ 137, 16, 137, 11 })
    ' 151366D8 | 8910               | mov dword [eax] , edx
    ' 151366DA | 890B               | mov dword [ebx] , ecx


    .子程序 取EIP, 整数型

    置入代码 ({ 139, 68, 36, 4 })  ' mov eax,[esp+4] 取ESP
    置入代码 ({ 131, 192, 251 })  ' add eax,-5
    置入代码 ({ 201 })  ' leave
    置入代码 ({ 195 })  ' ret
    返回 (0)
    [/ecode]
    欢迎加入乐易论坛VIP,报名联系QQ 43989835
    VIP介绍和课程安排
    回复

    使用道具 举报

  • TA的每日心情
    奋斗
    5 小时前
  • 签到天数: 637 天

    [LV.9]以坛为家II

     楼主| 发表于 2016-1-2 22:42:35 | 显示全部楼层
    视频中只是线上培训的一小部分,更多的需要去参加线上培训次啊能知道
    欢迎加入乐易论坛VIP,报名联系QQ 43989835
    VIP介绍和课程安排
    回复 支持 反对

    使用道具 举报

  • TA的每日心情
    擦汗
    2018-11-3 19:55
  • 签到天数: 7 天

    [LV.3]偶尔看看II

    发表于 2016-1-5 22:29:24 | 显示全部楼层
    不错哦不错哦不错哦不错哦不错哦不错哦
    欢迎加入乐易论坛VIP,报名联系QQ 43989835
    VIP介绍和课程安排
    回复 支持 反对

    使用道具 举报

  • TA的每日心情

    2019-1-26 21:23
  • 签到天数: 13 天

    [LV.3]偶尔看看II

    发表于 2018-12-28 14:07:45 | 显示全部楼层
    易汇编常见寄存器介绍以及使用
    欢迎加入乐易论坛VIP,报名联系QQ 43989835
    VIP介绍和课程安排
    回复 支持 反对

    使用道具 举报

  • TA的每日心情

    2019-3-13 19:49
  • 签到天数: 119 天

    [LV.6]常住居民II

    发表于 2016-1-2 22:50:28 | 显示全部楼层
    fffffffffffffffff
    欢迎加入乐易论坛VIP,报名联系QQ 43989835
    VIP介绍和课程安排
    回复 支持 反对

    使用道具 举报

  • TA的每日心情

    2019-5-9 10:31
  • 签到天数: 25 天

    [LV.4]偶尔看看III

    发表于 2016-1-2 23:30:12 | 显示全部楼层
    66666666666
    欢迎加入乐易论坛VIP,报名联系QQ 43989835
    VIP介绍和课程安排
    回复 支持 反对

    使用道具 举报

    该用户从未签到

    发表于 2016-1-2 23:41:51 | 显示全部楼层
    要算码吗。。。看看
    欢迎加入乐易论坛VIP,报名联系QQ 43989835
    VIP介绍和课程安排
    回复 支持 反对

    使用道具 举报

  • TA的每日心情

    2019-1-11 15:16
  • 签到天数: 14 天

    [LV.3]偶尔看看II

    发表于 2016-1-2 23:58:31 | 显示全部楼层
    很好的教程啊
    欢迎加入乐易论坛VIP,报名联系QQ 43989835
    VIP介绍和课程安排
    回复 支持 反对

    使用道具 举报

  • TA的每日心情
    开心
    2019-3-26 16:26
  • 签到天数: 24 天

    [LV.4]偶尔看看III

    发表于 2016-1-3 01:31:21 | 显示全部楼层
    很好好好的
    欢迎加入乐易论坛VIP,报名联系QQ 43989835
    VIP介绍和课程安排
    回复 支持 反对

    使用道具 举报

    该用户从未签到

    发表于 2016-1-3 14:08:24 | 显示全部楼层
    下载了 膜拜啊
    欢迎加入乐易论坛VIP,报名联系QQ 43989835
    VIP介绍和课程安排
    回复 支持 反对

    使用道具 举报

  • TA的每日心情
    无聊
    2018-10-25 12:01
  • 签到天数: 24 天

    [LV.4]偶尔看看III

    发表于 2016-1-3 14:32:55 | 显示全部楼层
    收藏了
    欢迎加入乐易论坛VIP,报名联系QQ 43989835
    VIP介绍和课程安排
    回复

    使用道具 举报

  • TA的每日心情

    2018-10-23 16:31
  • 签到天数: 4 天

    [LV.2]偶尔看看I

    发表于 2016-1-3 16:56:21 | 显示全部楼层
    易汇编
    欢迎加入乐易论坛VIP,报名联系QQ 43989835
    VIP介绍和课程安排
    回复

    使用道具 举报

    您需要登录后才可以回帖 登录 | 立即注册

    本版积分规则

    关闭

    乐易推荐上一条 /6 下一条

    QQ|网站地图|Archiver|手机版|小黑屋|乐易论坛 ( 湘ICP备19007035号-2 )

    GMT+8, 2019-7-19 16:48 , Processed in 0.088200 second(s), 78 queries , Redis On.

    Powered by Discuz! X3.4 Licensed

    © 2001-2017 Comsenz Inc.

    快速回复 返回顶部 返回列表